Компьютерные сети и технологии
Привет
Пользователь:

Пароль:



[ ]
[ ]

В сети
Гостей: 10
Участников: 0
На странице: 1
Участников: 5659, Новичок: Wonfrien


Команды управления IOS Cisco
Kоманды Cisco
на Thursday 13 April 2006
от список авторов
в Hardware > Оборудование Cisco


Сбор основной информации о маршрутизации

Команда show version предоставляет сведения о базовой аппаратной конфигурации системы, а также номер версии программного обеспечения, имена и источники конфигурационных файлов вместе с образом загрузки.

Router#sh version
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-JS-L), Version 12.0(8), RELEASE SOFTWARE (fcl)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Mon 29-Nov-99 14:52 by kpma
. Image text-base: Ox0305lC3C, data-base: 0x00001000
ROM: System Bootstrap, Version ll.O(lOc), SOFTWARE
BOOTFLASH: 3000 Bootstrap Software (IGS-BOOT-R), Version ll.O(lOc),
RELEASE SOFTWARE (fcl)
RouterA uptime is 5 minutes (маршрутизатор А работает 5 минут)
System restarted by power-on (система перезапущена по включению питания)
System image file is "flash:c2500-js-Ll20-8.bin" (файл образа системы)
cisco 2522 (68030) processor (revision N) with 14336K/2048K bytes of memory, (процессор cisco 2522 (68030) обновление N с 14336К/2048К байтами памяти)
Processor board ID 15662842, with hardware revision 00000003 (идентификатор процессорной платы 15662842 при аппаратном обновлении 00000003)
Bridging software. (программное обеспечение для функций моста)
Х .25 software. Version 3.O.O.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software. (программное обеспечение эмуляции TN3270)
Basic Rate ISDN software, Version 1.1. (программное обеспечение базового уровня ISDN версии 1.1)
1 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
8 Low-speed serial(sync/async) network interface(s)
1 ISDN Basic Rate interface(s)
32K bytes of non-volatile configuration memory. (32 Кбайта в энергонезависимой памяти конфигурации)
16384 К bytes of processor board System flash (Read ONLY) (16384 Кбайта в системной памяти флэш процессорной платы для режима "только чтение")
Configuration register is 0x2102 (конфигурационный регистр 0x2102)

С помощью команды show version можно узнать, как долго работает маршрутизатор, как он был перезапущен, имя исполняемого файла IOS, версии процессора и аппаратного обеспечения, а также размер памяти DRAM. Кроме того, указано значение в конфигурационном регистре.

Установка паролей

Для защиты маршрутизатора Cisco используются пять паролей. Первые два пароля служат для установки разрешенного пароля, который защищает привилегированный режим. Пароль запрашивается у пользователя после ввода команды enable. Остальные три пароля служат для настройки паролей для доступа пользователя через консольный порт, вспомогательный порт и по протоколу Telnet.

Разрешенные пароли

Для установки разрешенного пароля необходимо находиться в режиме глобального конфигурирования.

Router(config)#enable ?

last-resort

Define enable action if no TACACS servers respond

password
Assign the privileged level password
secret
Assign the privileged level secret
use-tacacs
Use TACACS to check enable passwords
Last-resort (крайний случай) Используется после установки аутентификации через сервер tacacs, который недоступен. Этот режим позволяет администратору даже в этом случае войти в систему маршрутизатора. Однако подобный режим недоступен при работающем сервере tacacs.

Password (пароль) Служит для установки разрешенного пароля (enable password) в устаревших системах с версиями до 10.3. Не используется, если установлен разрешенный секрет (enable secret).

Secret (секрет) Новый шифрованный пароль. После установки перекрывает действие разрешенного пароля.

Use-tacacs (использовать tacacs) Указывает маршрутизатору на аутентификацию через сервер tacacs. Это удобно, когда приходится обслуживать десятки и сотни маршрутизаторов. Как иначе изменить пароль на 200 маршрутизаторах? Сервер tacacs позволяет однократно изменить пароль, который будет действовать на все устройства.

Router(config)#enable secret todd

Router(config)#enable password todd


The enable password you have chosen is the same as your enable secret. This is not recommended. Re-enter the enable password, (выбранный разрешенный пароль совпадает с разрешенным секретом. Это не рекомендуется. Введите другой разрешенный пароль)

При попытке ввода одинакового разрешенного пароля и разрешенного секрета выводится вежливое предупреждение о недопустимости такого выбора. Однако при повторном вводе того же самого пароля, он будет установлен в маршрутизаторе даже при совпадении с разрешенным секретом. Между тем, пароли не работают одновременно. В новых маршрутизаторах (а не в старых унаследованных) можно не беспокоиться об использовании разрешенного пароля. Пароли пользовательского режима присваиваются командой line.



Aux (вспомогательный) Служит для установки пароля пользовательского режима для вспомогательного порта. Обычно применяется для настройки в маршрутизаторе параметров модема, но может служить и для доступа к консоли.

Console (консоль) Служит для установки пароля консоли пользовательского режима. Vty (виртуальный терминал) Служит для установки в маршрутизаторе пароля Telnet. Если такой пароль не установлен, то по умолчанию использование Telnet запрещено.

Для настройки паролей пользовательского режима сначала конфигурируется нужная линия (line), а затем вводится команда login или no login для вывода из маршрутизатора приглашения аутентификации.

Вспомогательный пароль

Для настройки вспомогательного пароля следует перейти в режим глобального конфигурирования и ввести line аuх ?. Список выбора содержит только строку 0-0, поскольку существует один вспомогательный порт.

Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#line aux ?
<0-0> First Line number
Router(config)#line aux 0
Router(config-line)#login
Router(config-line)#password todd


Важно помнить о команде login, иначе вспомогательный порт не выведет приглашения для аутентификации.

Пароль консоли

Для установки пароля консоли служит команда line console 0. Однако если подобно настройке вспомогательного порта ввести line console 0 ?, то вы получите ошибку. Необходимо ввести команду line console 0, причем после этого недоступен экран справки. Для возвращения на один уровень вверх следует задать " exit ".

Router(config-line)#line console ?
% Unrecognized command, ( нераспознанная команда )
Router(config-line)#exit
Router(config)#line console ?
<0-0> First Line number
Router(config)#line console 0
Router(config-line)#login
Router(config-line)#password todd1


Поскольку существует только один консольный порт, доступен вариант line console 0.

Другие команды консольного порта

Существует еще несколько важных команд для консольного порта, которые следует запомнить.

Команда exec-timeout О О устанавливает в ноль время тайм-аута консольного сеанса EXEC (т.е. тайм-аут запрещен). Можно разыграть своих коллег по работе, установив тайм-аут в значение О 1, что приведет к прерыванию терминального сеанса через каждую секунду! Избежать прерывания сеанса в этом случае позволит постоянное нажатие клавиши "стрелка вниз" при вводе изменения времени тайм-аута другой рукой.

Команда logging synchronous должна была бы быть установлена по умолчанию, но этого не сделано. Команда запрещает вывод консольных сообщений, которые прерывают ввод команд в консольном режиме. Это упростит чтение и ввод сообщений в маршрутизатор.

Примеры упомянутых команд:

Router(config)#line con 0
Router(config-line)#exec-timeout?
<0-35791> Timeout in minutes ( тайм - аут в минутах )
Router(config-line)#exec-timeout 0 ?
<0-2147483> Timeout in seconds ( тайм - аут в секундах )
< сг >Router(config-line)#exec-timeout 0 0
Router(config-line)#logging synchronous

Пароль Telnet


Для установки пароля пользовательского режима при доступе по Telnet к маршрутизатору служит команда line vty. Маршрутизаторы, которые не исполняют версию Enterprise операционной системы Cisco IOS, по умолчанию имеют пять линий VTY (от 0 до 4). Однако в версии Enterprise таких линий намного больше — 198 (0 — 197). Проще всего узнать количество линий с помощью вопросительного знака.

Router(config-line)#line vty 0 ?
<1-197> Last Line Number *
Router(config-line)#line vty 0 197
Router(config-line)#login
Router ( config - line )# password todd 2


Если попытаться установить сеанс Telnet с маршрутизатором, не имеющим заданных паролей для линий VTY, то будет получено сообщение об ошибке "подключение прервано, поскольку не установлен пароль". Можно указать маршрутизатору на разрешение подключений по Telnet без пароля, использовав команду no login.

Router(config-line)#line vty 0 197
Router(config-line)#no login


(После настройки IP-адреса маршрутизатора можно использовать программу Telnet для конфигурирования и проверки устройства вместо выполнения этих операций через консольный порт. Для запуска программы Telnet следует ввести в командной строке telnet (в DOS или Cisco).

Шифрование паролей

По умолчанию шифруется только пароль разрешенного секрета. Можно вручную установить режим- шифрования для пользовательского режима и разрешенного пароля. Заметим, что выполнение в маршрутизаторе команды show running-config позволяет увидеть все пароли за исключением разрешенного секрета.

Router # sh run
[листинг сокращен]
enable secret 5 $l$rFbM$8.aXocHg6yHrM/zzeNkAT.
enable password toddl
[ листинг сокращен ]
line con 0
password toddl
login
line aux 0
password todd
login
Iine vty 0 4
password todd2
login
Iinevty 5 197
password toddZ
login
!
end
Router#


Для шифрования паролей вручную следует выполнить команду service password-encryption. Пример шифрования пароля вручную:

Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#service password-encryption
Router(config)#enable password todd
Router(config)#line vty 0 197
Router(config-line)#login
Router(config-line)#password todd2
Router(config-line)#line con 0
Router(config-line)#login
Router(config-tine)#password toddl
Router(config-line)#line aux 0
Router(config-line)#login
Router(config-line)#password todd
Router(config-line)#exit
Router(config)#no service password-encryption
Router(config)# /v Z


После ввода команды show running - config мы увидим, что зашифрованы разрешенный пароль и пароли линий.



Баннеры

В маршрутизаторе Cisco допускается установка баннера (banner — приветственное сообщение), чтобы выводить его во время регистрации (входа) пользователя в систему маршрутизатора или администрирования этого устройства во время сеанса Telnet, например, баннер может выводить дополнительную справочную информацию (обычно баннеры изменяют для того, чтобы вид баннера по умолчанию не позволил злоумышленнику определить тип и модель обнаруженного в сети устройства, — Прим, пер.). Еще одной причиной изменения баннера является добавление предупреждения о защите для пользователей, обращающихся к устройству удаленно по объединенной сети. Доступны четыре разных баннера (в переводе на русский язык):

Router(config)#banner ?

LINE

с текст_баннера с, где 'с' является символом-разделителем

exec

Установка баннера для ЕХЕС-процесса

incoming
Установка входного баннера для терминальной линии
Login
Установка баннера входа в систему (регистрации)
motd

Установка баннера Message of the Day (ежедневного сообщения)

Чаще всего используется баннер Message of the Day, который выводится всем людям, подключающимся (в том числе по коммутируемым линиям) к маршрутизатору по Telnet, вспомогательному порту или консольному порту.

Router(config)#banner motd ?
LINE с banner-text с , where ' с ' is a delimiting character
Router(config)#banner motd #
Enter TEXT message. End with the character's 1 .
Sized to be in Acme.com network, then you must disconnect immediately
Router(config)# A Z
Router#

00:25:12: %SYS-5-CONFIG_I: Configured from console by console
Router#exit
Router con0 is now available

Press RETURN to get started.
If you are notauthorized to be in Acme.com network, then you must disconnect immediately. (если вы не авторизованы в сети Acme.com, то будете немедленно отключены)
Routeг>

Показанный баннер сообщает, что для подключения к маршрутизатору нужно пройти авторизацию. В противном случае произойдет отключение. Следует отметить использование разделителя. Можно применять любойсимвол, который укажет маршрутизатору на завершение сообщения. Следовательно, разделитель нельзя использовать в тексте баннера. Кроме того, для указания на завершение сообщения следует сначала нажать Return, затем ввести разделитель, а далее снова нажать Return. Если сделать иначе, то баннер тоже будет создан, но когда используются несколько баннеров, то они будут объединены в одно однострочное сообщение. Другие типы баннеров:

Баннер Exec Можно настроить баннер активизации линии (line-activation, exec) для вывода при создании процесса EXEC (например, для активизации линии или для входного подключения к линии VTY).

Входной баннер (incoming banner) Можно настроить баннер для вывода на терминале, подключенном по обратной линии Telnet. Этот баннер полезен для сообщения пользователю инструкций по использованию обратной процедуры Telnet.

Баннер регистрации (login banner) Можно настроить баннер регистрации для вывода на всех подключенных терминалах. Этот баннер появляется после баннера MOTD, но перед приглашением регистрации (входа в систему). Баннер регистрации нельзя отменить для отдельной линии. Для полного отказа от баннера регистрации следует удалить его командой по banner login.

Интерфейсы маршрутизатора

Конфигурация интерфейсов является наиважнейшей процедурой маршрутизатора. Без интерфейсов маршрутизатор бесполезен. Конфигурация интерфейсов должна взаимодействовать с другими устройствами. Среди конфигурационных параметров интерфейса: адрес сетевого уровня, тип носителя, полоса пропускания и другие административные характеристики. Разные маршрутизаторы используют различные методы выбора интерфейсов. Например, ниже показана команда для маршрутизатора серии 2522 с 10-ю последовательными интерфейсами (от 0 до 9):

Router(config)#int serial ?
<0-9> Serial interface number


После этого следует выбрать конфигурируемый интерфейс, затем мы попадаем в конфигурацию этого интерфейса. Например, команда выбора последовательного порта 5:

Router(config)#int serial 5
Router(config)-if)#


Маршрутизатор 2522 имеет один порт Ethernet lOBaseT. Ввод interface ethernet 0 начнет настройку этого интерфейса.

Router(config)#int ethernet ?
<0-0> Ethernet interface number
Router(config)#int ethernet 0
Router(config-if)#


Маршрутизатор серии 2500 имеет фиксированную конфигурацию, т.е. после покупки нельзя изменить состав этого устройства. Для настройки интерфейса нужно всегда использовать присвоенный интерфейсу порядковый номер. Однако маршрутизаторы серий 2600, 3600, 4000 и 7000 применяют физические слоты и номера портов для вставки в слоты съемных модулей. Например, в маршрутизаторе 2600 для конфигурирования нужно ввести interface type slot/port:



команду с фрагментом type slot/port или int fastethernet 0 / 0 . Кроме того, разрешено указать type int fa 0 / 0 .

Для установки типа подключения служит команда media-type. Однако обычно этот тип определяется автоматически.

Router(config)#int fa 0/0
Router(config-if)#media-type ?
100BaseX Use RJ45 for -TX; SC FO for -FX
Mil Use Mil connector

Включение интерфейса


Выключить интерфейс позволяет команда shutdown, а включить — no shutdown. Выключенные интерфейсы показаны с признаком "административно выключен" ( administratively down ) в выводе команды show interface . Однако команда show running-config продемонстрирует такие интерфейсы с признаком "выключено" (shut down). Все интерфейсы по умолчанию выключены.

Router#sh inte 0
Ethernet0 is administratively down, line protocol is down
[листинг сокращен]
Включение интерфейса командой no shutdown:
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int e0
Router(config-if)#no shutdown
Router(config-if)# ^ Z
00:57:08: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
00:57:09: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to up
Router#sh int e0
Ethernet0 is up, line protocol is up

Настройка IP-адреса интерфейса


He обязательно использовать протокол IP в маршрутизаторе, однако он применяется во всех маршрутизаторах. Для настройки IP-адреса интерфейса служит команда ip address в режиме конфигурирования интерфейса.

Router(config)#int e0
Router(config-if)#ip address 172.16.10.2 255.255.255.0
Router(config-if)#no shut


He забудьте включить интерфейс командой no shut. Например, проверить включение можно с помощью команды show interface eO. Она покажет состояние данного интерфейса (выключен или включен административно). Команда show running-config тоже покажет выключенные интерфейсы.

Если требуется добавить интерфейсу второй адрес подсети, следует применить команду secondary. Если ввести другой IP-адрес и нажать Enter, то будет заменен существующий IP-адрес и маска подсети. Для добавления второго IP-адреса используйте команду secondary.

Router(config-if)#ip address 172.16.20.2 255.255.255.0 secondary
Router(config-if)# A Z


Проверить конфигурирование обоих адресов интерфейса можно с помощью команды show running-config (сокращенная форма: sh run).

Router#sh run
Building configuration...
Current configuration:
[ листинг сокращен ]
I
interface Ethernet0
ip address 172.16.20.2 255.255.255.0 secondary
ip address 172.16.10.2 255.255.255.0


Карты VIP

В маршрутизаторах серий 7000 и 7500 с картами VIP (Versatile Interface Processor — многоцелевой интерфейсный процессор) определение интерфейса выполняется командой interface type slot / port adapter / port number , например:

7000(config)#interface ethernet 2/0/0

Команды последовательного интерфейса

Для настройки последовательного интерфейса нужно знать его особенности. Интерфейс подключается к устройству типа CSU/DSU, которое обеспечивает тактовую частоту в линии. Однако если в лабораторной среде используется конфигурации "один к одному", то только один участник соединения должен предоставлять тактовую частоту. Это может быть оконечное кабельное устройство DCE. Маршрутизатор Cisco по умолчанию является устройством DTE, поэтому необходимо явно указать интерфейсу на предоставление тактовой частоты, если этот интерфейс работает в режиме ВСЕ. Настройка последовательного интерфейса на режим ВСЕ выполняется командой clock rate (уровень тактовой частоты).



Установка тактовой частоты в интерфейсе не приведет ни к каким поломкам, но нужно знать, что команда clock rate предполагает значение в битах в секунду.

Кроме того, следует знать о команде bandwidth. Любой маршрутизатор Cisco поставляется с установленной в последовательных интерфейсах полосой пропускания для линии ТГ(т.е. скорости 1.544 Мбит/с). Однако это никак не влияет на скорость пересылки данных по линии. Значение полосы пропускания используется в протоколах маршрутизации IGRP, EIGRP и OSPF для вычисления наилучшей стоимости пути к удаленной сети. Если применяется маршрутизация RIP, то значение полосы пропускания не учитывается.

Router(config-if)#bandwidth ?
<1-10000000> Bandwidth in kilobits
Router(config-if)#bandwidth 64


В отличие от команды clock rate, команда bandwidth устанавливает значение в килобитах.

Имена хостов

Для установки имени хоста в маршрутизаторе служит команда hostname. Это имя действует локально, т.е. не учитывается во время просмотра маршрутизатором имен в объединенной сети.

Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname todd
todd(config)#hostname Atlanta
Atlanta (config)#


Хотя кажется, что лучше выбрать для имени хоста собственное имя,рекомендуется именовать маршрутизаторы по географическому признаку.

Описание

Установка описания интерфейса поможет администратору, но, как и имя хоста, описание действует только локально. В нем можно указать дополнительные характеристики интерфейса, например номер цепи.

Atlanta (config)#int e0
Atlanta (config-if)#description Sales Lan
Atlanta (config-if)#int s0
Atlanta (config-if)#desc Wan to Miami circuit:6fdda4321


Для просмотра описания интерфейса служат команды show running- config и show interface .

Atlanta #sh run
[ листинг сокращен ]
interface Ethernet0
description Sales Lan
ip address 172.16.10.30 255.255.255.0
no ip directed-broadcast
[
interface Serial0
description Wan to Miami circuit:6fdda4321
no ip address
no ip directed-broadcast
no ip mroute-cache
Atlanta #sh int e0
Ethernet0 is up, line protocol is up
Hardware is Lance, address is 0010.7be8.25db (bia 0010.7be8.25db)
Description: Sales Lan
[ листинг сокращен ]
Atlanta #sh intsO
SerialO is up, line protocol is up
Hardware is HD64570
Description: Wan to Miami circuit:6fdda4321
[листинг сокращен]
Atlanta#

Просмотр и сохранение конфигурации


Пройдя все операции процедуры установки, мы получим приглашение на сохранение созданной конфигурации. Если ответить yes, то конфигурация будет записана в память DRAM (т.е. станет исполняемой конфигурацией) , в память NVRAM или в файл с именем startup-config. Можно вручную скопировать файл из DRAM в NVRAM командой сору

running-config startup-config. Краткая форма данной команды: copy run start also .

Router#copy run start

Destination filename [startup-config]?return

Warning: Attempting to overwrite an NVRAM configuration previously written by a different version of the system image. (предупреждение: попытка перезаписать в NVRAM конфигурацию, записанную из другой версии образа системы)

Overwrite the previous NVRAM configuration?[confirm]return (перезаписать предыдущую конфигурацию в NVRAM)

Building configuration... (построение конфигурации)

Обратите внимание, что сообщение говорит о попытке записи поверх старой конфигурации startup-config. Операционная система IOS была обновлена до версии 12.8, но при последнем сохранении файла использовалась версия 11.3.

Для просмотра файла используйте команду show running-config или show startup-config в привилегированном режиме. Команда sh run (краткая форма show running-config) укажет на просмотр текущей конфигурации.

Router#sh run

Building configuration...
.
Current configuration:
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
|
hostname Router
ip subnet-zero
frame-relay switching
|
[ листинг сокращен ]

Команда sh start (краткая форма show startup - config ) покажет конфигурацию, которая будет использоваться при следующей перезагрузке маршрутизатора, а также выведет объем памяти NVRAM для хранения файла startup-config.

Router#sh start

Using 4850 out of 32762 bytes

version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
ip subnet-zero
frame-relay switching
!
[ листинг сокращен ]

Можно удалить файл startup-config командой erase startup-config. После этого выводится ошибка при попытке просмотра файла конфигурации запуска (startup-config).

Router#erase startup-config

Erasing the nvram filesystem will remove all files! Continue? [confirm]
[OK]
Erase of nvram: complete ;
Router#sh start
%% Non-volatile configuration memory is not present ( нет энергонезависимой памяти конфигурации )
Router #

Проверка конфигурации


Разумеется, лучше всего проверить конфигурацию во время просмотра командой show running - config . С помощью команды show startup - config можно проверить конфигурацию, установленную для загрузки при следующем перезапуске маршрутизатора. Однако после проверки исполняемой конфигурации running-config, когда все будет в порядке, можно дополнительно проверить конфигурацию утилитами Ping и Telnet.

Проверить по Ping другой протокол позволит ввод ping ? в пользовательском или привилегированном режиме маршрутизатора.

Router#ping ?

WORD Ping destination address or hostname

appletalk

Appletalk echo

decnet

DECnetecho

ip
IP echo
ipx
Novell / IPX echo
srb

srb echo

< cr >Для поиска адреса сетевого уровня соседнего устройства следует переместиться к маршрутизатору или переключателю, либо ввести show cdp nei detail для получения сведений об адресе сетевого уровня, по которому будет обращаться утилита Ping. Можно использовать программу Trace для поиска пути, по которому движутся пакеты в объединенной сети. Допускается трассировка по нескольким протоколам.

Router#trace ?

WORD Trace route to destination address or hostname

appletalk

AppleTalk Trace

clns

ISO CLNS Trace

ip
IP Trace
oldvines

Vines Trace (Cisco)

vines

Vines Trace (Banyan)

Большие возможности имеет Telnet. Эта утилита использует протокол IP на сетевом уровне и TCP на транспортном уровне для создания сеанса с удаленным хостом. Если можно обратиться к устройству по Telnet, следовательно, корректно подключение по IP. По Telnet можно обращаться только к IP-адресам, но допустимо использование хостов Windows или приглашения маршрутизаторов для применения утилиты Telnet.

Router#telnet ?

WORD IP- адрес or hostname of a remote system

В приглашении маршрутизатора не обязательно вводить команду telnet. Если ввести имя хоста или IP-адрес, то по умолчанию предполагается использование Telnet.

Проверка командой Show Interface

Еще один способ проверки конфигурации связан с использованием команды show interface. Сначала рекомендуется ввести show interface ?, чтобы увидеть все доступные для конфигурации интерфейсы. Единственные интерфейсы, которые не подчиняются общим правилам, — это Ethernet и Serial (последовательный).

Router#sh int?
Ethernet IEEE 802.3
Null Null interface
Serial Serial
accounting Show interface accounting
crb Show interface маршрутизация /bridging info
irb Show interface маршрутизация /bridging info
Следующая команда show interface ethernet 0 покажет аппаратный адрес, логический адрес и метод инкапсуляции, а также статистические данные о конфликтах.

Router#sh int e0
EthernetO is up, line protocol is up
Hardware is Lance, address is 0010.7b7f.c26c (bia 0010.7b7f.c26c)
Internet address is 172.16.10.1/24
MTU 1500 bytes, BW10000 Kbit, DLY1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:08:23, output 00:08:20, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40,0 drops; input queue 0/75,0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
25 packets input, 2459 bytes, 0 no buffer
Received 25 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 input packets with dribble condition detected
33 packets output 7056 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

Наиболее важными в листинге команды show interface являются сведения о выходных линиях и о статусе протокола канального уровня. Если включен интерфейс Ethernet 0, то включены протоколы линии. Кроме того, работает сама линия.

RouterA#sh int e0
EthernetO is up, line protocol is up


Первый параметр относится к физическому уровню. Он включен, когда приемник это обнаружил. Второй параметр связан с канальным уровнем и указывает на время поддержания жизни (keepalive) на другом конце связи.

RouterA#sh int s0
Serial0 is up, line protocol is down


Если линия включена, но выключен протокол, возникают проблемы с тактовой частотой (keepalive) или кадрами. Проверьте значение параметра keepalive на обоих концах связи. Эти значения должны совпадать, должны быть установлены тактовые импульсы (при необходимости) и совпадать тип инкапсуляции на обоих концах соединения.

RouterA#sh int s0
Serial0 is down, line protocol is down


Если же выключены линия и протокол, то проблемы связаны с кабелем или с интерфейсом. Кроме того, если один конец связи выключен административно, то следует выключить и удаленный конец. Для включения интерфейса введите команду no shutdown in interface configuration.

RouterB#sh int s0
Serial0 is administratively down, line protocol is down


Следующая команда демонстрирует последовательную линию с установленным по умолчанию значением MTU (Maximum Transmission Unit — максимальный передаваемый элемент) равным 1500 байт. Кроме того, по умолчанию на всех последовательных линиях Cisco полоса пропускания (BW, bandwidth) равна 1.544 Kbs (Кбит/с). Это значение служит для подсчета полосы пропускания в протоколах маршрутизации IGRP, EIGRP и OSPF. Еще один важный конфигурационный параметр — время поддержания жизни (keepalive) по умолчанию равен 10 с. Любой маршрутизатор посылает своему соседу сообщение keepalive через каждые 10с. Если оба маршрутизатора не настроены на одинаковый интервал keepalive, то поддержание жизни не получится.

Для очистки счетчиков в интерфейсе служит команда clear counters.



Использование команды Show Controllers

Команда show controllers показывает сведения о самом физическом интерфейсе. Она также выводит тип последовательного кабеля, подключенного к порту. Обычно таким кабелем является только кабель DTE, который подключается к интерфейсу в режиме DSU (Data Service Unit).

Router#sh controllers s 0
HD unit 0, idb = Oxl229E4, driver structure at Oxl27E70
buffer size 1524 HD unit 0, V.35 DTE cable
cpb = OxE2, eda = 0x4140, cda = 0x4000
Router#sh controllers s 1
HD unit 1, idb = Oxl2C174, driver structure at 0x131600
buffer size 1524 HD unit 1, V.35 DCE cable
cpb = ОхЕЗ , eda - 0x2940, cda = 0x2800

Заметим, что интерфейс serial 0 имеет кабель DTE, хотя к serial 1 подключен кабель ВСЕ. Интерфейс serial 1 будет обеспечивать в линии тактовую частоту, установленную командой clock rate. Но интерфейс serial 0 будет получать тактовые импульсы от кабеля DSU. Следует помнить, что это единственная команда, после которой необходим пробел.

Router#sh controllers s1
% Invalid input detected at ' Л ' marker.

Страница
1 : Часть 1
2 > : Часть 2

Поиск Компьютерные сети и технологии


Copyright © 2006 - 2016
При использовании материалов сайта ссылка на xnets.ru обязательна!
Render time: 0.0640 second(s); 0.0252 of that for queries. DB queries: 29. Memory Usage: 4,475kb